среда, 16 ноября 2011 г.

openSUSE python scriptengine

В русском переводе: не может создать движок python.
Такая ошибка может появиться при использовании таких плазмоидов, как:
gmail-plasmoid, veromix, magic folder и, думаю, многих других
На сайте gmail-plasmoid написано, что:
Note: If you get missing script-engine errors when loading the widget you need to install the plasma python script-engine (in openSUSE this is the "python-kdebase4" package, in Fedora it is the "kdebase-workspace-python-applet" package, in Kubuntu this requires the "plasma-scriptengine-python" package)
Надеюсь и без перевода понятно, в каких пакетах для каких дистрибутивов находится этот самый движок питона (plasma python script-engine).
Несмотря на наличие python-kdebase4; в установленной openSUSE 12.1 (в 11.4 так-же было) - плазмоиды не работают.
Им не хватает python-devel пакета, который дополнительно потянет за собой glibc-devel и linux-glibc-devel.
В результате сводка установки будет выглядеть следующим образом (если не выбирали что-то дополнительно):

Соглашаемся с выбором, ждём пока всё заинсталится, завершаем сеанс (перегружаться не надо, надо просто разлогиниться и снова зайти - log off/log on в английском варианте) снова заходим под своим пользователем и пользуемся плазмоидами.

Комментариев нет:

Отправить комментарий